Drupal issues emergency fix for critical bug with known exploits

by chebbi abir

Drupal has released emergency security updates to address a critical vulnerability with known exploits that could allow for arbitrary PHP code execution on some CMS versions.

“According to the regular security release window schedule, November 25th would not typically be a core security window,” Drupal said.

“However, this release is necessary because there are known exploits for one of core’s dependencies and some configurations of Drupal are vulnerable.”

Right now, over 944,000 websites are using vulnerable Drupal versions out of a total of 1,120,941 according to official stats. “These statistics are incomplete; only Drupal websites using the Update Status module are included in the data,” Drupal says.

Drupal is also used by 2.5% of all websites with content management systems, making it the fourth most popular CMS on the Internet, after WordPress (63.8%), Shopify (5.1%), and Joomla (3.6%).

Security updates for all affected versions

According to Drupal’s security advisory, the vulnerability is caused by two bugs in the PEAR Archive_Tar library used by the content management system (CMS) tracked as CVE-2020-28948 and CVE-2020-28949.

The critical Drupal code execution vulnerability can be exploited if the CMS is configured to allow and process .tar, .tar.gz, .bz2, or .tlz file uploads.

Multiple Drupal security updates were issued to fix the bug and to allow admins to quickly patch their servers to protect them from potential attacks.

Drupal recommends installing the following updates on affected servers:

  • Drupal 9.0 users should update to Drupal 9.0.9
  • Drupal 8.9 users should update to Drupal 8.9.10
  • Drupal 8.8 or earlier users should update to Drupal 8.8.12
  • Drupal 7 users should update to Drupal 7.75

“Versions of Drupal 8 prior to 8.8.x are end-of-life and do not receive security coverage,” Drupal’s security team said.

Mitigation measures also available

Mitigation measures are also available for admins who cannot immediately update the Drupal installation on their servers.

To do that, site admins are advised to block untrusted users from uploading .tar, .tar.gz, .bz2, or .tlz files to temporarily mitigate the issue.

Department of Homeland Security’s Cybersecurity and Infrastructure Security Agency (CISA) has also issued an alert today urging admins and users to upgrade to the patched Drupal versions.

Last week, Drupal patched another critical remote code execution vulnerability tracked as CVE-2020-13671 and caused by improper filenames sanitization for uploaded files. 

“Pay specific attention to the following file extensions, which should be considered dangerous even when followed by one or more additional extensions: phar, PHP, pl, py, cgi, asp, js, HTML, htm, and phtml” the company said. 

“This list is not exhaustive, so evaluate security concerns for other unmunged extensions on a case-by-case basis.”

To read the original article:



Interdit de copier  ce contenu